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Getting Help

Via Email and Telephone
· Technical questions about the R4 application should be addressed to

r4template@cdie.usaid.gov. Or you can call 703-351-4006 8:30 AM to 4:00 PM EST.

· Questions about how to report performance should be sent to Parrie Henderson-OÕkeefe,
PPC/PC, at phenderson@usaid.gov.

Via the Internet
· CDIE also provides technical support online at http://cdie.usaid.gov/r4_2003/.

Help materials that come with the application, accessible through the help menu:
· This userÕs guide, intended to provide in-depth information on how to use the

application

· The How-to file, which provides quick tips on how to do common tasks

· The tutorial, an illustrated PowerPoint presentation that takes you step-by-step through
the application

· The FY 2003 R4 Guidance Cable, PPCÕs official instructions for how to prepare R4s.

Help inside the templates
6. In MS Word templates, we again use the Òhidden textÓ attribute of MS Word to add

non-printing excerpts from the guidance to help explain how whatÕs required for that
template. To turn hidden text on, click on the paragraph symbol button in the MS Word
toolbar.

7. WeÕve added many Òtool tipÓ hints to the application. Holding the cursor over most any
button or field will cause a ÒhintÓ to appear on screen that explains what that button or
field is for.

8. ThereÕs a help button in the indicator data entry screen that includes a relevant excerpt
from the guidance about indicator tables.
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Introduction and overview

Your work in the R4 template typically will consist of editing the preloaded text, changing
or adding new indicators, and preparing the final document for submission to Washington.
The contents of the R4 are separated into smaller chunks to facilitate processing the data
into PPCÕs R4 database in Washington. The application is tightly integrated with MS Word
and Excel to make handling these chunks easier, and automates the process of combining
them into a single file for transmission to Washington.

The steps one would typically take to prepare an R4 via the application are as follow:

1. Launching and logging in

2. Editing the preloaded data in Word templates, indicator data tables, spreadsheets and
annexes

3. Adding new SOs and indicators if needed

4. Proofing and Review

5. Printing

6. Transmission

This guide covers all these steps, and also includes sections on using the application to
manage performance monitoring plan (PMP) indicators and using the application in a multi-
user environment.
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What’s new

This yearÕs R4 application is significantly different -- and, we feel, vastly improved -- over
last yearÕs templates. The product of an extensive review of user feedback, the FY 2003 R4
application addresses a number of shortcomings in the old template and is significantly
easier to use and more powerful.

The R4 application uses a completely new front-end to manage and combine the MS Word
templates used last year to create the R4s. The application consists of three tightly
integrated parts: first, a front end that guides you through the process of creating the R4 and
automates all file management and document integration chores; second, a set of MS Word
templates for the R4 narrative sections; and third, a separate MS Access database that
contains all indicator data.

NOTE: As was the case last year, the spreadsheets that make up most of Part II are NOT
managed by the application. The spreadsheet files are included in the tree view of the entire
R4, and can be opened by double clicking on them in the tree, but the spreadsheets are NOT
included in the full R4 document when the Merge Documents command is invoked, nor are
they automatically emailed to Washington during the transmission process.

Key features:
Automated file management and document compilation: the application handles all file
naming and directory management chores, and automates the task of combining separate
Word templates into a single final document.

Automated transmission of final document to Washington. Procedures for emailing
complete documents to Washington have been greatly simplified.

Improved spell check: you can spell check within any component part of the R4, or spell
check the entire document after itÕs been compiled.

New indicator database: the application uses an new Access database module to store
indicator data, and the indicator data table template has been replaced by an indicator data
entry screen that serves as a front end to the Access database.

PMP module: The applicationÕs indicator database includes a PMP module that makes it
easy to track all your indicators, not just the ones youÕre reporting in the R4.
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Installation

System Requirements
To run the application, youÕll need the following:

1. Pentium grade PC or better w/ Windows 95, NT, 97, or 2000

2. 5 Mb free disk space

3. 64 Mb of RAM

4. MS Office 97 (Service Release 2)

5. Email connectivity (for automated transmission feature)

6. A LAN connection (optional, for use with multiple users)

Installation instructions

About the install instructions
Instructions are provided below for installing the R4 application on a standalone
workstation or in a client-server configuration on a LAN. To perform the install on a local
PC, youÕll need to unzip several archive files, and save them to specific locations on your
PC. For a LAN install, youÕll need to install some files to your PC, and others to a shared
drive on the LAN. YouÕll also need to make some site-specific modifications to the .INI file
that accompanies the application.

Non-technical users should be able to perform a standalone install by following the
instructions below. LAN installations should be done by your LAN administrator.

Downloading the application
CDIE has prepared customized R4 applications for all units that submitted an R4 for FY
2002. You can download your application at http://cdie.usaid.gov/r4_2003/getr4step1.cfm.
The download procedure asks you to provide some basic contact information about
yourself, which CDIE uses to track R4 application use.

Once the download process is complete, youÕll have received a self-extracting archive
called [unit_name].exe.

What your .exe file contains
Double click on the .exe file and youÕll be asked for a location to save the extracted files. Specify
C:\

The .exe file will create a new directory on your computer, C:\r4process\. The r4process directory
will initially contain three separate .zip files:
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· [Name]_client.zip: This archive includes the R4 application itself (r4process.exe) and
several related resource files.

· [Name]_network.zip: Contains all the data files from your FY 2002 submission (e.g.,
SO narrative templates, indicator data, etc.)

· [Name]_system32.zip: This archive includes several BPL (similar to DLL) files

required by the application.

For standalone workstations
Specific instructions for installing the application for use on a single PC follow.

1. Download the custom application from CDIEÕs web site (see above).

2. After downloading is complete, double click on the executable (it will be called [unit
name].exe (e.g., tanzania.exe or gegad.exe).

3. A dialog will appear asking you to specify a location to save the extracted files. The
default will be  C:\. Leave this as the default and click OK.

4. The archive will create a new directory on your PC at the root level of your C:\
drive, called r4process. Open the directory, and youÕll see three separate .zip files,
called [name]_client.zip, [name]_network.zip, and [name]_system32.zip. Double
click on [name]_client.zip.

5. The WinZip licensing screen will appear. Click ÒI acceptÓ and a standard WinZip
window will appear with the contents of the archive listed in the pane at the bottom.
Click on the Extract button at the top of the page.

6. A dialog box like the one in step 3 will come up, asking you to specify a location for
the extracted files. If not already the default, type in C:\.  The files will be extracted
and placed in your r4process directory.

7. Next, double click [name]_network.zip. Follow steps 5 and 6 for this archive as
well. As in step six, make sure you extract the files to C:\.

8. Next, double click on [name]_system32.zip, and follow step five. This time youÕll
need to enter a different path to which youÕll extract the files. If you running
Windows 95 or 98, type in C:\win\system32\ instead of C:\. If youÕre running
Windows NT, type in C:\winnt\system32\.

9. Your install is complete. NOTE: You may need to edit the INI file if you find that
the application cannot communicate with your Email application. See step 11 in the
instructions for LAN installations.

For LAN installations
LAN installations require that the contents of [name]_network.zip be saved to a shared
Network drive. This means that youÕll also have to edit the INI file to tell the application
what drive the shared files are on. If youÕre uncomfortable with any of this, ask for help
from your LAN administrator.

1. Download the custom application from CDIEÕs web site (see above).
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2. After downloading is complete, double click on the executable (it will be called [unit
name].exe (e.g., tanzania.exe or gegad.exe).

3. A dialog will appear asking you to specify a location to save the extracted files. The
default will be  C:\. Leave this as the default and click OK.

4. The archive will create a new directory on your PC at the root level of your C:\
drive, called r4process. Open the directory, and youÕll see three separate .zip files,
called [name]_client.zip, [name]_network.zip, and [name]_system32.zip. Double
click on [name]_client.zip.

5. The WinZip licensing screen will appear. Click ÒI acceptÓ and a standard WinZip
window will appear with the contents of the archive listed in the pane at the bottom.
Click on the Extract button at the top of the page.

6. Next, double click [name]_network.zip. Instead of C:\, type in the drive letter of the
shared drive on which you wish the files to reside (e.g., H:\). If youÕre not sure what
drive letter to use, see your LAN administrator.

7. Next, double click on  [name]_system32.zip. Extract these files to the C:\ drive on
your local PC. The file-copying portion of the install is complete.

8. The INI file for the R4 application (r4system.ini) was installed in the C:\r4process\
directory. Open the INI file in Notepad by double clicking it.

9. Scroll down in the file. File the the following lines:

[Network Path]
Drive=C

10. Change the drive letter in the second line to the drive letter of the shared drive you
copied the [name]_network.zip files to in step 6 above.

11. Scroll down some more, and find the following lines:

[Storage Paths]
Drive =C

12. Change the drive letter to the letter of the shared drive, as in step 9.

13. Scroll down some more, and find the following line

[Mail Services]

14. Look at the lines immediately following, which identfy to the application where on
your network various email applications reside. Verify that the path to the email
system in use at your site is correct. For example, if youÕre using BeyondMail, find
the following line:

Beyondmail=Y:\BmAppDes\Email\prog32\BMAILW.exe

15. If the path to the Beyond Mail application on your LAN is different (e.g., is on the U
drive instead) type in the correct path (e.g.,
Beyondmail=U:\BmAppDes\Email\prog32\BMAILW.exe).
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Installing Microsoft MDAC files
The R4 application requires version 2.1 or later of the Microsoft Data Access Components
to run. Most Office 97 installations will have these files already. A quick way to check is to
open any Office application and select About [app name] from the Help menu. If the
abbreviation ÒSR 2Ó Ñ Service Release 2 ÑÊappears in the dialog box  (e.g., in Access the
About box would say ÒMicrosoft AccessÓ with ÒSR 2Ó in little letters below) then you
should have the required MDAC files installed.

If the files are not present, you could see a number of problems in using the application,
especially system errors when trying to open indicator data records from the tree view.

If you need the MDAC files, youÕll have to download a separate file, MDAC.exe. You can
download a copy off the same page you downloaded the R4 application, or you can
download them directly from Microsoft at
http://www.microsoft.com/data/download_250rtm.htm.

For standalone installations, the MDAC files go on your C:\ drive. For LAN installations,
the MDAC files must be installed on your file server.

To install the MDAC files, follow these steps

· Double click on MDAC.exe

· Follow the instructions on screen. NOTE: the install program will only install
new files if it detects that you have an older version.
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Using the application

What you get
Installation of the prepopulated R4 application copies creates a directory called r4process on
your hard disk. Most of the time youÕll never have to worry about any of the files in this
directory, but for the record hereÕs a list of what they are:

16. r4process.exe, the R4 application front end

17. A set of MS Word templates pre-populated with the narrative data from your FY 2002
R4 submission. There are two basic kinds of templates -- templates that use the MS
Word forms feature to capture narrative in separate fields, and ÒregularÓ or non-fielded
templates that behave as ordinary MS Word documents. These are included in the
doc_data directory.

18. An Access database with records for all the indicators reported in the FY 2002 R4. This
is stored in the mdb_data directory.

19. A set of budget spreadsheets for use in the resource review section of the R4, in the
xls_data directory.

20. Help files used by the application: a PowerPoint tutorial, in the tutorial directory, this
user guide (user_guide.doc), and a quick Òhow toÓ reference file (r4help.doc)

21. A template directory containing blank SO narrative templates used by the application in
creating new SOs

22. A copy of the FY 2003 guidance, in MS Word form

23. A number of application resources, in a directory called BPLS

24. A PMP data directory

25. A blank performance data table template, in MS Word format (included in case you
decide not to use the application)

26. A file called r4system, which is another application resource

27. A readme file, containing the latest information about your application

A note about sources and accuracy
The data that comes with your application is the same data that was submitted to PPC/CDIE
for use in CDIEÕs R4 database. Objective ID numbers, objective names, and indicators all
reflect what was in that original R4 submission. Every effort has been made to ensure that
what you get in the FY 2003 application is what you submitted in FY 2002.

In some cases, however, the data from the FY 2002 R4s is not the last word on a unitÕs
programs. For example, changes in the R4 as a result of the review process can introduce
new objectives or indicators that may not be included in the application. We recommend
that you carefully review the data included in your R4 to ensure that all objectives are
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present and accounted for. In cases where a change has occurred since the last R4, youÕll
need to add a new SO to describe that activity (see Step Three below).
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Step One: Launching the application

First, make sure that MS Word and Excel are NOT running. Launching the application
while these applications are open can cause trouble on some systems.

Double click on the application icon the installer placed on your desktop. This should be
called r4process.exe.

YouÕll see a welcome screen, followed by a screen with some last-minute notes about the
application, and finally a login screen. The application ships with no security in place, so
leave the password box blank and click OK. (See the section ÒUsing the application in a
multi-user environmentÓ for instructions on setting up logins for the application).

The tree view
The tree view, familiar to users of Windows Explorer, provides an intuitive way to view the
contents of your R4 document. Each part of the document is contained in the tree hierarchy;
double clicking on a plus sign next to an item expands to tree to reveal that sectionÕs
subcomponents. Expanding an SO, for example, would reveal the indicators for that SO.

Choose ÒExpand AllÓ from the Menu to fully expand the tree. Double clicking on any of the
narrative sections in the tree view will launch MS Word and load the appropriate document.

PMP Data mode
The application displays an alternate tree view if you click on the PMP Data button. In this
mode, the tree view shows a list of SOs, with all the indicators that are in the database (not
just the ones used in the R4). Indicators selected for inclusion in the R4 are marked in both
views with two asterisks before the indicator name. See Step 2 below for more on selecting
indicators for use in the R4.

The menus
The menus in the application are as follows.

File
The file menu contains only the Exit command to quit the application. Choosing ÒExitÓ here
is the same as clicking ÒexitÓ on the button bar.

NOTE: EXIT only closes the R4 application, not any MS Word or Excel sessions you might
also have running concurrently. Remember to save changes made in Word and Excel
documents before closing.

Edit
The edit menu contains the usual Cut, Copy and Paste commands.
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Document

Merge Documents
the Merge Documents command takes all the MS Word templates and indicators youÕve
marked for inclusion in the R4 and combines them into a single MS Word File. The file it
creates is always called [countryname]02fullr4.doc and it is saved in the doc_data directory.
See Step 5 for more on the Merge documents command

Print Document

Indicator document
Choose this command to print an indicator table from the tree view. Select the indicator in
the tree, then choose this command. NOTE: in order to print data tables, first check the
ÒClick to include indicator in FY R4 reportÓ box  in the Performance Data Table data entry
screeen.

SO Narrative document
Choose this command to print a portion of the R4 narrative from the tree view. The name is
a bit misleading, since the command prints any section of the narrative, not just SO
narratives. To print, first select the narrative part of the R4 you want to print from the tree,
then choose this command. You can also open the template and print from inside MS Word.

Preview full document
Choose this command to view an MS Word print preview of your full R4 document. You
must first create the full R4 document via the Merge Documents command.

Print full document
Choose this command to print a hard copy of the full R4 document. You must first create
the full R4 document via the Merge Documents command.

Display

Update
This command refreshes the tree view. Sometimes youÕll need to refresh the tree using this
command in order to make it reflect recent changes.

Expand
Expands all headings in the tree to review all component parts of the R4
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Collapse
Collapses all headings in the tree so that only the major section headings remain

You can click on the plus and minus buttons in the tree view to selectively expand or
collapse individual headings.

Maintenance

Add SO
Click to add a new SO to the tree. Has the same functionality at the +SO button; see Step
Three for a detailed description of how to add an SO.

Add indicator
Click to add a new indicator to the tree. Has the same functionality as the + Indicator
button. See Step Three for a detailed description of adding indicators.

Delete SO
Deletes the selected SO from the tree

Delete Indicator
Deletes the selected indicator from the tree

See Step Three for detailed information on deleting SOs and indicators.

Connection
The Connection menu is used in conjunction with the applicationÕs email feature to suspend
and restore internal database connectivity as needed.

For example, some email clients require that the applicationÕs internal database connection
(which powers, among other things, the tree view) be interrupted before email can be sent.
The application will automatically disconnect when Email R4s button is clicked. At that
point the tree view window goes gray and the application can no longer be used. If, after
sending the email, you wish to return to using the application, restore the connection using
the Connect command.

Help
From the help menu, you can access the following help files:

· Tutorial

· Users Guide

· How to file

· FY 2003 R4 Guidance
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The button bar
The button bar provides quick access to commonly used commands.

Exit
Exits the application. Sessions in other applications (e.g., MS Word) initialized by the R4
application remain active.

Update
Refreshes the tree display

Expand
Expands the tree view

Collapse
Collapses the tree view

+ SO
Adds a new SO to the tree view

+ Indicator
Adds a new indicator to the tree view

Email R4s
The E-Mail R4s button activates the applicationÕs automated email function. See Step Six
for detailed instructions.

PMP Data
Switches the tree view to PMP mode, which displays all SOs and indicators. See the section
on the PMP Module below.

Contextual menus
Most of the menu commands and button functionality can also be accessed via Windows
contextual menus. For example, to print an SO narrative, you can also right click on the
item you want to print, and select Document>Print Document>SO Narrative from the pop
up contextual menu. This has the same functionality as selecting the command from the
menu bar.
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Step Two: Working with last year’s data

To begin work on your R4, double click on a section of the document you wish to edit.

The application automatically will launch MS Word and load the file corresponding to the
section you clicked.

Editing text in narrative sections
Editing text in the templates is fairly straightforward. Like last year, the cover page, SO
Narrative sections, and the Results Framework Annex are in form-field based templates.
You can edit the text inside the shaded form field sections, but not any other part of the
document. Use the tab key to move the cursor quickly from field to field. As you tab
through the fields, brief help messages will appear in the status bar at the bottom of the
window.

The cover memo, Part I Overview, and Part III Resource Request, and all Annexes except
the Framework Annex are contained in regular MS Word documents. The application
imposes no technical restriction on what these documents can contain.

See Step Four below for information on spell checking within narrative templates.

Editing indicator data
To work with indicator data in the application, return to the tree view and double click on an
indicator table. Each indicator table is listed beneath its related strategic objective in the tree
diagram.

The application will open an indicator data entry screen. The data entry screen will contain
all the data for that indicator reported in last yearÕs R4. The screen includes fields for all
parts of the indicator data table, and two sets of buttons.

At the top are a set of buttons for posting the entire indicator table record to the database;
below is a second set of buttons for manipulating the year/planned/actual portion of the
record.

To edit any of the data from last year, simply click in the field you wish to edit and change
the text as appropriate.  You can enter up to 16,000 characters in each of the fields.

Adding/deleting rows in the performance data section
You can add rows as needed to the year/planned/actual section of the record using the
second set of buttons below that portion of the screen. To add a row, click the ÒplusÓ button.
The row is added to the top of the display. Enter data in this row as needed, then click the
ÔpostÕ button (the one with the curly arrow). The new row is posted to the database, and
should be sorted by year. Typically the new row would be to add a new yearÕs worth of
data, and so would appear as the last row in the display.
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Disaggregated data
A new field in the indicator data table this year is the Òdisaggregated byÓ field. The new
field DOES NOT solve the long standing limitation of not being able to report
disaggregated data in the same data table in the final R4 document, but using the
Òdisaggregated byÓ field WILL permit the display of disaggregated data in a single data
table on the web via PPCÕs R4 database.

Discussion
At present, the Access database that manages the indicator data in the application cannot
accommodate more than one indicator in the same data table. For example, a unit that
wishes to report on primary school enrollment disaggregated by gender cannot include
numbers for ÔmalesÕ, ÔfemalesÕ, and total in the same data table. Each disaggregated number
must be in its own data table.

Last year, the R4 guidance specified a limit of four indicator tables per SO. In the case
above, reporting on this one disaggregated indicator would use up three of the four allotted
indicator tables.

To lessen this problem somewhat, the guidance now removes the limitation on the number
of indicator tables you can report. Though you still cannot report disaggregated data in same
indicator data table, you can use the Òaggregated byÓ field to indicate that the data is
disaggregated and what the disaggregation is.

In the case above, the unit would enter ÒMalesÓ in the Òdisaggregated byÓ field for the table
that includes the data on male enrollment, ÒFemalesÓ in that field for the next one, and so
on.

Even though in the final R4 document these disaggregated indicators will appear in separate
indicator data tables, using the Òdisaggregated byÓ field will permit the display of
disaggregated data in a single data table on the web via PPCÕs R4 database.

Selecting indicators for inclusion in R4 document
Another new feature in the indicator data entry screen is the Òinclude indicator in final FY
R4 documentÓ check box. This is a database flag that the application uses when generating
the final R4 document. Only records in the database that have this box checked will be
included by the application in the final R4 document.

By default, NO INDICATORS are selected. YOU MUST CHECK THIS BOX IF YOU
WISH THE INDICATOR TO BE INCLUDED IN THE FINAL R4 DOCUMENT.
Indicators that have been selected appear in the tree view with two asterisks (**) before the
indicator name. This check box makes it possible to track indicators in the PMP module of
the database, which you would not necessarily, wish to report in the R4. See the section on
the PMP module below for more information.

NOTE: Only data tables that have been selected for inclusion in the final R4 document can
be printed via the Document>Print Document>Indicator Doc command. To print data tables
that have not been selected for use in the full R4, use the PMP module (see the section on
the PMP Module below).
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Saving changes to the database
Once the indicator data has been edited, click on the curly arrow in the top set of buttons to
post the changes to the database.  This is the same as doing a save.

Working with budget spreadsheets
The budget spreadsheet files are included with your application in the xls_data directory
and can be accessed via the tree view. To open a budget file, double click on its file name in
the tree view. You must print spreadsheets from within Excel. The spreadsheets are NOT
preloaded with last yearÕs data. Note that the guidance asks that ALL spreadsheet files be
returned with the R4, even ones that are not used.

The spreadsheets are NOT integrated with the rest of the R4 material in the application,
however. This means that the Merge documents command will not include the spreadsheets
in the final merged R4 document, and that the global spell check macro will not spell check
inside the spreadsheets. When you submit your R4, you must remember to include all the
spreadsheet files in your email -- they will not be included automatically.

As stand-alone Excel files, youÕre free to work with them as you would any spreadsheet.
Questions about the spreadsheets should be referred to M/B/RA.

Working with annexes
The supplemental annexes that appear at the end of the R4 are all MS Word templates. With
the exception of the Framework annex, if you completed an annex last year the
corresponding annex template in the application will be pre-populated with that data. You
can work with them as you would any MS Word file.
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Step Three: Adding new SOs, IRs, and indicators

ItÕs much easier this year to add or delete SOs and indicators to your R4.

Adding SOs
To add an SO, click on the ÔSO +Õ button in the button bar at the top of the tree view. The
application responds with a dialog box asking you to confirm that you want to add an SO.
The dialog also has a text entry field that contains a suggested Objective ID (OBJID)
number. The suggested number is based on the existing SOs in your application: for
example, if the last SO in the application was 161-011, the suggested OBJID would be 161-
012. You can either click OK to have the application create a new SO with the suggested
OBJID, edit the suggested OBJID, or CANCEL.

We strongly recommend that you consult the master list of Objective ID numbers before
accepting any ÒsuggestedÓ SOs offered by the application. This Master list, compiled by
PPC, is available online at http://www.dec.org/r4_2003/r4prep.cfm. Accidentally reusing an
OBJID can cause errors in PPCÕs R4 database and can result in delays in having your R4
processed and made available online. If youÕre adding an SO that was approved after your
last R4 submission, chances are you should be able to find its official OBJID in the master
list.

If the suggested OBJID does not appear in the master list, then you can click OK to create
the SO using the suggested OBJID.

Once you click OK, a dialog comes up confirming that the new SO has been created. The
tree is redrawn. The new SO should appear at the bottom of the SO narrative section of the
tree diagram. If you canÕt see it, click the Òrefresh displayÓ button in the button bar to force
the application to redraw the screen.

Double click on the new SO to open a fresh SO narrative template for editing. The template
should already include the new OBJID in the OBJID field.

Adding Indicators
Adding new indicator records is easy. In the tree view, click on the SO you want to add an
indicator to select it. Next, click the Ô+ IndÕ button in the tool bar. A dialog comes up asking
you to verify the objid for the SO you want to add the new indicator to. Click OK, and the
application creates a new indicator record and automatically opens the data entry screen for
the new indicator. The objective name, OBJID, approval data and country/organization
fields are automatically filled in if that information appears in other indicators for this SO.

KNOWN BUG: there is a known bug in the application that occurs when you create a new
S0. When you create new SO, then immediately create a new indicator for that SO, clicking
on the Òinclude this indicator in R4Ó check box in the indicator data entry screen will cause
the application to freeze. Workaround: create the SO, then create the indicator. Without
checking the Òinclude in the R4Ó box, click on the top checkmark button on the indicator
data entry screen to post the indicator data to the database. In the tree view, click the
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Ôupdate displayÓ button to make sure the application is aware of the new indicator record.
At this point you can go back into the indicator and check in the Òinclude in R4Ó box
without error.

Deleting SOs and Indicators

Deleting SOs
Ordinarily you should not need to delete SOs and Indicators, and in fact we discourage it.
Deleting SOs deletes not only the SO but also the indicators associated with the SO. The
indicators are permanently removed, not just from the R4 part of the application, but from
the PMP section as well. Deleting SOs is NOT undoable.

To delete an SO, click on the SO you want to delete in the tree view, the select ÒDelete SOÓ
from the Maintenance menu. A dialog comes up asking you to confirm that you want to
delete the SO. Click OK, and a second dialog asks you to verify the OBJID of the SO you
want to delete. If the OBJID is correct, click OK; if not, type in the correct OBJID and click
OK. A third dialog comes up, offering you a last chance to change your mind. If youÕre
certain you want to delete, click yes. A final dialog confirms that the SO has been deleted.

Deleting Indicators
A less drastic approach is deleting individual indicators. Still, deleting indicators is
permanent and removes the indicator record both from the R4 and PMP portions of the
application, and cannot be undone.

It may be enough to simply uncheck the Òinclude this indicator in R4Ó box on the indicator
data screen, instead of deleting the entire indicator. This prevents the indicator from
appearing in the R4, but retains it in the database for use in the PMP module.

To delete an indicator, select in the tree view the indicator you want to delete. Then choose
ÒDelete IndicatorÓ from the Maintenance menu. A dialog asks you to confirm. Click ÒYes.Ó
A dialog comes up confirming that the indicator has been deleted.
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Step Four: Document proofing and review

Spell check

Spell check within the application

Spell checking narrative text

In form-field based templates
One of the enhancements in the MS Word templates this year was the inclusion of a special
spell check macro. This macro makes it possible to spell check the contents of form fields
within the template itself.

The macro is invoked by double clicking a special text link Ò Click for Spell checkÓ at the
top of the template. This text has the hidden attribute applied to it, so it will not print in the
final document. If you canÕt see the text link, make sure youÕve set hidden text to be visible
by clicking on the Paragraph button in the MS Word toolbar.

Once invoked, the macro brings up the standard MS Word spell check dialog. Spell check
as you normally would.

In non-fielded templates
Non-fielded templates (cover memo, Part I Overview, etc.) can be spell checked in the same
manner as any other MS Word document. No special macros or commands are required.

Spell checking indicator tables
You can spell check any individual field within the indicator data entry screen by right-
clicking in the field you want to check, and selecting Òspell checkÓ from the contextual
menu.

You canÕt spell check the entire table from within the data entry screen, but you can catch
any errors by using the spell check macro to check the entire final document (see below).

Spell checking the final MSWord doc
In addition to spell checking within the individual sections of the R4, you can also use the
spell check macro to spell check the entire R4 document after it has been merged (for more
on creating the final merged document, see Step 5 below). To spell check the entire
document:

Open the final unified R4 document by choosing Document>Print Document>Preview Full
Document. MS Word brings a print preview of the final document. Choose View>Normal
to bring up the document in normal mode.
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A link to the spell check macro (Ôclick here for spell checkÕ) is at the top of the document,
in blue hidden text. If you canÕt see the hidden text, make it visible by clicking on the
paragraph symbol in the main tool bar.

Click on the link to invoke the macro. Once invoked, the macro brings up the standard MS
Word spell check dialog. Spell check as you normally would.

Preparing electronic and paper-copy drafts for review

Drafts and versioning issues
The applicationÕs abilitity to compile and print the R4 at any time makes it easy to distribute
hard copy or electronic versions for review purposes. ItÕs vital, though, to make sure that the
version of the R4 in the application is amended to reflect any changes made in these stand-
alone draft versions.

For example, if you were to produce a draft R4 using the merge documents command, and
then gave that file to a colleague for review. Your colleague made some changes to the
narrative for SO 1 in that draft file. The draft file is now out of synch with the application.
Any edits made to SO 1 would not be reflected in the application until you went back to the
application and keyed (or cut and paste) the changes from the draft file into the SO narrative
template for SO 1.

For this reason, you need to be very careful in distributing draft versions of the R4, and
make sure that the version in the application is the one that reflects all changes and edits.
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Step Five: Printing

You can use the Document>Print Document menu to print draft copies of the R4, either in
part or whole, at any time. You can also print the MS Word sections of the R4 from within
Word itself if you wish.

NOTE: If you encounter problems printing to a network printer using the Document>Print
Document menu, try rebooting your network print server.

Formatting limitations

Rearranging SOs
Strictly speaking, you cannot rearrange SOs within the application. SOs are automatically
assigned their place within the document according to their objective ID number -- that is,
SO 186-001 will always be the first SO,  186-002 will always be second, and so on.

You can change the order in which SO narratives appear in the Results Review section after
you create the final merged Word document for the R4. Simply cut and paste narratives into
whatever order you wish.

Headers and Footers
Individual sections of the R4 will NOT include any headers or footers, including page
numbers when printed from the application. The Merge Document command WILL insert
page numbers into the footer of the full R4 document (see the section on headers and footers
below.

Charts and graphs
In general, PPC discourages the use of charts and graphs in the R4 document, since they can
cause problems in loading r4 data into the database. The application WILL NOT allow you
to add charts and graphs within SO narratives or indicator data tables. You can, however,
insert charts, graphics, or tables in the R4 overview section (i.e., Part I).

Desktop publishing
You can also use the final merged document that the application produces as the basis for a
desktop-published version of the R4. If you choose this route, you can of course format the
document as you see fit. The catch is that your changes will not be reflected in the R4
database.  If you add significant portions of narrative in sidebars or other design elements
not included in the merged R4 document from the application, the narrative data WILL
NOT be included in the R4 database. Plus youÕll need to send CDIE a PDF version of your
enhanced R4 in order for it to be posted on the R4 web site. Please contact CDIE at
r4submit@dec.cdie.org if youÕre producing a DTP version of the R4 for additional
submission information.
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Printing part of the R4
You can print any part of the R4 using the Document>Document Print menu. You can print
a draft of the entire R4 as a single MS Word document, or you can print individual
templates or indicator tables (to print indicator tables, they must first be selected for
inclusion in the full R4. See Step Two above).

The basic procedure is to select the part of the R4 you want to print in the tree view, then
select the appropriate kind of document you wish to print from the menu. For example, if
you wanted to print a draft copy of a given SO narrative, you would select the SO from the
tree, then select Document>Print Document>SO Narrative from the Print document menu.
In the case of an indicator table, you would select the indicator from the tree, then choose
Document>Print Document>Indicator.

Printing the entire R4 document
Printing the full R4 document means 1) creating the full R4 document by using the Merge
Documents command, then 2) printing the full R4 using the Document>Print
Document>Print Full Document command. You can also do a print preview of the full
document by selecting Document>Print Document>Preview Full Document.

The Merge Documents command
To print the whole document, first you must create a merged MS Word original. Select
Document>Merge Documents to merge the individual Word templates and indicator data
tables into a single Word document for the entire R4. This document is automatically
named [country or unit name]03fullr4.doc and saves it in the doc_data directory.

· The full R4 document this command creates includes the following elements:

· The cover page

· The cover memo

· Standard R4 boilerplate

· Table of Contents (generated automatically by application)

· Glossary

· Part I: Overview

· All SO narratives and indicator data records marked for inclusion in R4

· Part III: Resource Request overview

· All annexes (even if blank)

The full document WILL NOT include any of the spreadsheet files for the resource review.
It will include ALL the annexes, whether you said anything in them or not. If you wish to
remove the blank annexes, you must do so manually.

It is important to remember that the Merge Documents command produces a merged, stand-
alone version of your entire R4 in a single document. The key thing here is Òstand aloneÓ --
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once you produce a merged document, changes made to that document ARE NOT reflected
in the application.

Also keep in mind that the Merge Documents command ALWAYS creates a file with the
standard name ( [country or unit name]03fullr4.doc) in the same place (the doc_data
directory). This means that if youÕve created a full R4, then select ÒMerge DocumentsÓ
again, the application will automatically overwrite the first full R4 with the new one. If you
want to preserve successive versions of the full R4 document (to have a record of changes,
for example), be sure to copy the full R4 document out of the doc_data directory before
using the Merge Documents command.

Headers and Footers
The Merge Documents command automatically inserts page numbering into the footer of
the full R4 document. You can edit the footer, or add a header, in the full document in the
same manner as you would any Word document (e.g., via the View>Header and Footer
command in Word).

Print preview
Once youÕve created the full R4 document, you can use the Document>Print
Documents>Print Preview command to bring up an MS Word print preview of your final
document. You can close the preview and correct any errors in the full R4 document.

Print final
Once youÕre satisfied with the full R4 document, you can use the Document>Print
Document>Print full document command to print the entire R4 to your local printer.
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Step Six: Transmission of complete R4

The application greatly simplifies the process of transmitting the R4 to Washington. If your
unit has moved to Microsoft Outlook as its email client, then the transmission process is
almost completely automated. Users of Beyond Mail and other systems will have to work a
little harder, but it will still be much easier than last year.

Where to send it
Consult the Section III of the guidance cable for bureau-specific guidance on where to
submit R4s.  The guidance cable is included as part of the application (select
Help>Guidance), or you can access it online at http://cdie.usaid.gov/r4_2003/r4prep.cfm.

What gets sent
The following files are sent via email as part of your R4 submission:

· the full R4 document ( [country or unit name]03fullr4.doc, in the doc_data
directory).

· the Access database containing all the indicator data for your R4 (permaster.mdb in
the db_data directory.

· ALL the files in the xls_data directory

Note that Guidance asks that ALL budget spreadsheets be returned, even if blank. The
application will automatically add all annexes to the full R4 document, even if they are
blank (see the section on Merge documents in Step Five).

How to transmit your R4 to Washington:
1) Click on the arrow next to the ÒEmail R4Ó button and select your email system from the

menu (the choices are Outlook, Beyond Mail, Blue Mail, and Dial Up.

If your email client is Outlook:

2) Once you select Outlook from the menu, the application brings up a new email form.
The application automatically fills in the subject line and attaches the necessary files
from your r4process directory. All you need do is enter the email address for your
contact person in the bureauÕs DP office, and hit send. See Section III in the R4
guidance for Bureau-specific information on where R4s should be emailed.

If your email client is anything other than Outlook:

2) The application brings up a blank email form. YouÕll need to fill in the subject line and
the address of the person youÕre sending the R4 to.

3) YouÕll also have to manually attach the following files from your r4process directory:

· the full R4 document ( [country or unit name]03fullr4.doc, in the doc_data
directory).
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· the Access database containing all the indicator data for your R4 (perfdata.mdb in
the mdb_data directory.

· ALL the files in the xls_data directory

4) Click the send button. If your local email system has a restriction on the size or number
of email attachments, you may need to use multiple emails to transmit all the files.
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Using the application in a multi-user environment

The R4 application can be a valuable tool in a multi-user environment. Its built in file
management tools can greatly simplify team-based document authoring.

LAN installation
To work in a LAN setting, the application must be installed in a client/server configuration.
That is, the indicator database and MS Word templates for the r4 narrative reside on a
shared network drive, while the front end application must be installed on each workstation
that will be used to work on the R4.

Specifically, the xls_data, doc_data, and mdb_data directories are installed on the shared
network drive, while everything else (e.g., the application, related help files, BPLS
directory, etc.) are installed on each workstation.

Limitations

Windows NT
Since Windows NT only allows one user read/write access to a particular file at a time, only
one person can work on any one MS Word template at a time. For example, each SO
narrative is a single MS Word file; person A can open the file via the application and have
full access. If person B tries to open the same file while person A has it open, Windows will
ask person B if they would like to open a read-only version of the file. Person B could,
however, work on a different SO narrative while person A works on their file.

This limitation is largely avoided in the indicator table portion of the application. Multiple
users can access and modify the same indicator database record at the same time with no ill
effects. The only caveat is that multiple users cannot edit the same field within an indicator
at the same time.

Banyan Vines
Banyan networks are less rigid in the ways they assign rights to individual files, and this can
cause real problems when two or more people try to work on the same file at the same time.
In the example above, if both person A and person were on a Banyan network, both would
be allowed to open the SO narrative file with read/write privileges.

Both would think that they had exclusive access to the file. In fact, the version of the file
that is last saved will be the copy that is preserved. So if A and B are making different
changes to the file independent of each other, and should A save and close the file before B,
the next time A opens the file he/she will find the version B saved, with BÕs edits. AÕs
changes will have been overwritten and lost.
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Setting logins and security
The application allows for logins to be assigned to provide security, but ships without a
password. Contact your network administrator for more information about adding security
to shared files used by the application.
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PMP module

The R4 application includes a new Performance Measurement Plan (PMP) module designed
to help operating units manage all their indicators, not just the ones they report in the R4.
The PMP was developed in conjunction with PPC and reflects the latest ADS guidance.

Accessing the PMP module
To access the PMP module, click the ÒPMP DataÓ button in the button bar. The tree view
should redraw to display a list of all SOs and all related SOs, whether theyÕve been flagged
for use in the R4 or not. In effect, youÕre seeing the entire contents of the indicator database.

Using the application to manage PMP
Double clicking on one of the indicators in the PMP view will bring up the PMP-specific
data entry screen for the indicator.

The PMP screen includes all the fields from the standard R4 indicator data table, plus
additional fields:

· Presentation of data

· Review of Data

· Reporting of Data

· Initial data quality assessment

· Baselines and targets notes

· Dissaggregated by

· Management Utility

· Data Collection Method

· Data Collection Frequency

· Estimated cost of collection

· Responsible organization

· Data analysis

· Key to Table

· Known data limitations

· Actions addressing limits

· Method of calculations

All of these extra fields will be blank when you receive your template. Last yearÕs data, as
reported in the R4, will be preloaded, however.
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Adding indica tors
Unfortunately, you canÕt add indicator records directly while in PMP mode. To add an
indicator, youÕll need to return to the R4 mode by clicking the Òshow R4 dataÓ button, and
then clicking the Òadd indicatorÓ button.

Printing PMP indicators
Use the Create PMP Report button on the PMP data entry screen to print draft copies of
PMP indicator tables. NOTE: This is the ONLY way to print PMP indicators; the
Document>Print Document>Indicator Doc command only works with indicators that have
been selected for inclusion in the full R4.

Using PMP module with other systems
All the data for the indicators in the application are included in the MS Access database.
You can use this database as a stand-alone tool, if you wish, or export the data to an existing
system.

IMPORTANT: be sure to COPY the database out of the directory, so that you leave the
original database file in its original location. Renaming or moving the database file in the
app directory will cause the application to break.


